Help - Search - Members - Calendar
Full Version: Liquid Mod Ii Analog Mode Awful
Plugivery Forums > Official Manufacturers Forums > Nomad Factory
andyjh
Putting Liquid Mod II into analog mode, just sounds like a bit crusher, it's not useful, It's just a horrid distortion

is this just a bug, or is it really supposed to sound like this ?
Ashley Smith
Hi Andy,

Check the Overdrive amount, make sure you aren't smashing it. I advise you re-install latest version from the "All Previous Products" installer and hit up our tech support team with your full system spec's, examples, settings, etc, if you're having/hearing any issues.

Regards,
andyjh
QUOTE (Ashley Smith @ Jun 12 2017, 02:56 PM) *
Hi Andy,

Check the Overdrive amount, make sure you aren't smashing it. I advise you re-install latest version from the "All Previous Products" installer and hit up our tech support team with your full system spec's, examples, settings, etc, if you're having/hearing any issues.

Regards,



Thanks for the reply,

The overdrive is OFF (as is Feedback and Width), I have updated to the latest version, and the problem is still there. The input level is about -12dB, what does make it better, is to drive the input to 0dB and reduce the output to -12dB.

The question is, what is the Analog mode supposed to do, it just seems to be an overdrive effect, and an unpleasant one at that - maybe this is what it is supposed to do ?

It does sound all OK in Digital mode
Ashley Smith
Hi Andy,

The analog mode simply offers a different topology design and sound (focussed high-end and more weighted lows) of the circuit, and essentially the writ/coded algortihm. It should not and in tests to confirm here for Chorus or Flanger type impart unpleasant overdrive/distortion (though you may hear some smoothed saturation for modeled "analog" componets, as expected); 'less you are driving the input excessively for that particular or desired inflection, which would be digital, not clipping, distortion.

Best,
greenroom
Been fine in analog mode using Liquid Phaser II in Logic 10.4, only distortion is w/ drive on. Curious if it's only happening in Mod II.


QUOTE (andyjh @ Jun 13 2017, 12:57 AM) *
Thanks for the reply,

The overdrive is OFF (as is Feedback and Width), I have updated to the latest version, and the problem is still there. The input level is about -12dB, what does make it better, is to drive the input to 0dB and reduce the output to -12dB.

The question is, what is the Analog mode supposed to do, it just seems to be an overdrive effect, and an unpleasant one at that - maybe this is what it is supposed to do ?

It does sound all OK in Digital mode

This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.